Subsection page not found, red herring for template issue?

I’m having issues using subsections in /content/. I created a very simple sandbox at GitHub - moniquemurphy/sandbox: Sandbox for whatever to try to resolve the issue without a theme.

Files in question are content/index.html

I created a baseof.html template, as well a list.html and single.html templates in layouts/_default/.

localhost:1313/ worked out of the box, as expected. Pointed to /content/index.html.

When I first went to localhost:1313/translations/, I got a 404 error. I changed the front matter to say layout: single and type:single. The page then rendered and pointed to content/translations/index.html. I removed layout: single and type: single and it still worked. Not sure if this is because of caching, or some sort of behavior in Hugo that sets the correct template location permanently after it’s set? I found this odd.

I cannot access localhost:1313/translations/hobonichi/ no matter what. I set the layout and type manually like with one level up. It didn’t work. I tried manually adding index.html to the url, it redirected to localhost:1313/translations/hobonichi but with a 404. Thank you for any help in advance!

mv content/index.html content/_index.html
mv content/translations/index.html content/translations/_index.html