Filename for a nested index page?

I’m trying to get /architecture/anjees-chalet/ to point to my file.

I’ve got a setup like this

I’ve also tried:

Locally, the index.html pages work.
Oddly, when restarting the server, the index.html pages 404, but if I make an edit and save, they work OK. What’s up with that? (Same happens when I name them

The live site (hosted on Netlify) also 404’s on the two index.html pages
Wondering why this is, and what I can do to solve it.

Here’s the repo
Thank you, and happy holidays :santa:

You need to look in the documentation and understand the difference between leaf and branch bundles in Hugo.

The “now it works, now it doesn’t” effect you see is parallelism at play.

1 Like

Thanks for pointing me in the right direction.
Trying to digest this awesome writeup:

Tried renaming the subfolder index files to, but that doesn’t seem to be right.

Also tried to accomplish /architecture/anjees-chalet/ by :

Read all the docs. All of them. But first, read

If you want a page to render at, you want one of the following:

  • /content/architecture/
  • /content/architecture/anjees-chalet/

You should not have a theme folder in content, or any HTML files (it is possible, but for advanced uses, and this is a very basic use).

@maiki No worries, Arthurs-Theme is not a theme (It’s the name of a restaurant).

Right, I am trying to have: and

I’ve tried both of your suggested structures, but no luck :man_shrugging:

I do also have /content/architecture/ to serve as the page, hope that’s OK.

Thanks for your help!

Nope. Bjørn told ya to understand the difference between lead and branch bundles. I’m not sure you need an anywhere, since you are loading your galleries via shortcode.

When I move your files into place, and use the following for the architecture directory, the site works as expected:


You’d need a reason to not use this structure.

1 Like

Edit: Solved: I needed to create a template for my

I’m trying my best.
Read and read, but not clicking for me just yet.

My structure is now: and are loading now, awesome!

However is blank for me. Any advice?
Here’s what I see in the Chrome console if it’s of any use:

Appreciate the help.