Website won't load on Google Chrome on Android devices

I have recently added a few new features on a website (a gallery viewer using glightbox and a toggle navbar button). The website with all its features works fine on computers and Apple devices and on some browsers on Android, but it doesn’t work on the Google Chrome browser and throws the Aw, Snap! error at me.

I have now tried to remove the features and turn the page right back to a version with no javascript, because that was the first thing to come to my mind that could cause problems. The error still persists.

I also tried to remove all photos from the site. Now this worked and the website loaded. Putting the photos back with a significant quality and size reduction, however, doesn’t seem to work.

Does anybody know how to fix this? Or, does anybody have the same problem?

git: astropi-hackathon-website

your website is very large I think you add many images arround the 10Gb of size

this image from your site crashed my browser:

It loaded for me but the image is 10532x10532 pixels, even though it is compressed to 382Kb it is a 100 megapixel image!!

Oh my God, guys, thank you so much, you’re life saviors. Yeah I totally disregarded the image size and resolution. My friend just gave it to me and I only changed the format. Really, thank you so much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.