Turn off pagination


#1

In my config.toml I’ve set paginate = 99 because I have fewer than 99 pages and I do not want pagination pages. When I run hugo, the public directory contains a page/1 directory. How do I tell hugo not to create the page directory. Looking at gohugo.io/getting-started/configuration/, the settings that might be related to a solution to this are these:

# Allows you to disable all page types and will render nothing related to 'kind';
# values = "page", "home", "section", "taxonomy", "taxonomyTerm", "RSS", "sitemap", "robotsTXT", "404"
disableKinds = []
 :   
# Pagination
paginate =                    10
paginatePath =                "page"

I tried setting paginate = 0 but that produced this error:

error calling Paginator: ‘paginate’ configuration setting must be positive to paginate

Is there a way to turn off pagination?

Thanks.


#2

Only by not using it in the templates.