Cannot disable pagination in terms page, even after removing .Paginator

I want to disable paginations on terms page. So in terms.html, I changed {{ range .Paginator.Pages }} to {{ range .Pages }}.

And here is what i wrote on Pagination.

{{ if .Paginator }}
        {{ if gt .Paginator.TotalPages 1 }}
        ......
        {{ end }}
{{ end }}

But Hugo still generates pagination. The pagination keep existing, and I can even access http://localhost:1313/categories/page/2/.

I’ve searched some articles on this. However, I still can’t solve this question. In this post, bep said,

Those pages only gets generated if you reference the Paginator in a template. So don’t and you should be home free.

But there isn’t anything related to pagination in terms.html. Pagination still exists.

There is another case, just like what i’ve said, in this post: Turn off pagination

Please provide a link to a public repository for your site.

Thanks for your reply.

I’ve put them in a branch taxonomy: https://github.com/AmazingRise/hugo-theme-diary/tree/taxonomy/

This is the related page terms.html:

And here are the paginator of PC view:

, and also mobile view: