Prevent pagination from being created

I’ve modified my blog home page so that it does not support pagination. I’ve got 5k+ blog entries and no one’s ever going to iterate through them all. However, Hugo is still generating all the folders and index pages for this feature. Is there some way to completely disable this?

Those pages only gets generated if you reference the Paginator in a template. So don’t and you should be home free.

Yep - and I found where I had forgotten to remove one code. I honestly didn’t think I’d get a response this quick - hence me not rushing back to update the post. :slight_smile: Thank you!

1 Like