[SOLVED] Github pages fail to build/deploy

I used to have a Jekyll site on Github and have now migrated to Hugo (yay)

I’ve followed the excellent guide here: https://gohugo.io/tutorials/github-pages-blog/

and have my repo here: https://github.com/Svenito/unlogic

As you can see I have a master branch with the Hugo source files, and a gh-pages branch with the results of the build. This is pretty much what the jekyll site was set up like too.

The issue is though that I always get a build error from Github:

Your site is having problems building:
Page build failed. For more information, see help.github.com/articles/troubleshooting-github-pages-build-failures.

No more information than that. I’m not sure what it’s trying to build as I am pushing the generated site. Of course, the site and pages aren’t working : unlogic.co.uk

Thinking that it might be because the old blog used to be a Jekyll site (but generated locally before pushing), I deleted the repo and recreated it. Still no luck.

I saw someone who had a similar problem here, but that thread offered no working solution.

Any help as to how I can go about troubleshooting this would be great.

Missing links because I can’t add more than two links.

EDIT: I have narrowed down the error to the assets/css/main.scss file from the hugo-minimalist theme. So I guess this could be an error in the theme?


@Unlogic Have you tried moving the repo to unlogic.github.io? I believe GH pages looks for this first, then checks for Jekyll, then checks for a gh-pages branch.

I’ve managed to isolate it to a .scss file that the theme has. This is the only file that causes the build to fail, but without it, it doesn’t render properly.

I’m trying some other themes now

Just tried setting it up with a proper submodule and was able to: http://minhajuddinunlogic.zammu.in/
I used Zammu for Auto Deployment http://hugo.zammu.in/how-i-publish-my-blog-posts-using-hugo/

Let me know once you checkout so that I can remove the duplicate site :slight_smile:

Thanks @minhajuddin but I’ve switched to the Pixyll theme now, which works out of the box. I might as well just leave a comment on the hugo-minimalist repo now, as it seems more a problem with the theme than hugo itself.

EDIT: Turns out that file isn’t in the theme. Although it listed the theme’s name inside the file, I have no idea where it came from. I cleaned out the theme directory and the static/assets folders and rebuilt the site. All working now.

Thanks for the help everyone