Gh-pages 404

gh-pages wont deploy site! I think I’ve tried everything but I keep getting 404:

  • I added the .nojekyll file (and tried adding a jekyll theme too while having and not having the .nojekyll file because)
  • I added a Github Action Workflow
  • theme is connected with a submodule

Everything runs great locally, here is the public repo GitHub - lexahl/1

Site should be here

I think I need a second (or third) set of eyes looking at this - thank you!!

If you look into your config, you are lacking baseURL = "".
I would start with setting this up to ?

I have base url “” on the main branch to test on netlify, on the gh-pages branch it is set to, and the deploy for gh pages is on that branch, thanks for the suggestion though :))

You are using GitHub Pages action · Actions · GitHub Marketplace · GitHub. That action deployed your site to the gh-pages branch. The gh-pages branch then contains whatever Hugo generated in the “public” director.

Your “gh-pages.yml” workflow also checks that the deploying branch is “main” but your default branch is named “master”.

i changed main to master, but still not working…

You missed the first part of my post. This line need to be changed to “master”.

ah ok - i tried changing that too but it also made no difference… :frowning:

It still say “gh-pages”:

It is on the master branch you need to make the change.

That is the branch you should deploy from.

On each deploy the workflow will override anything in the gh-pages branch with the generated site, i.e. the content of the “public” folder.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.