Hugo --destination public --> no pictures or icons appear

Dear Forum

I would like to deploy my first Hugo test website.
It works nicely on my Macbook now, when running the “hugo server -D”.

To deploy the Hugo Website I do:

hugo --destination public

and I then copy the content of the created “public” folder to my webserver.

On that server the pictures (png-files) and the icons (like mail paper plane and small arrows) are not shwon.

Am I using the correct and complete command?

When I hover above the “?” that are shown on the website instead of the picturees with my mouse, there is nothing shown.
I am sure that people will ask for my web-address, but I would not like to post this here, if that’s ok.
But I can send it with a private message?

I hope the information is sufficient to point me into the right direction.


Partially this is solved.

My mistake was that I did not use the correct website in the config.toml

baseURL = “

The Pictures work now as expected.

The icons don’t work yet, which I did not yet find out why.

Actually when looking on the demo page of the Theme, the icons don’t seem to work there neither.
Is this the same for someone else as well?

The icons show up only as little blue boxes on my computer.

View your browser’s console log. This is what I see in Chrome:

Thank you JMooring

That shows it very clearly!

I understand now why it does not work for the Demo Page and I get the same error message on my page:

Mixed Content: The page at ‘’ was loaded over HTTPS, but requested an insecure font ‘’. This request has been blocked; the content must be served over HTTPS.

Big question is now how to fix that :slight_smile:

Let’s see …