Icons still not showing on production server

With reference to my earlier post (Site page not populating and icon not showing) I still have the issue of icons in menus showing on localhost but not on production server. I see the icons on the server so it should be ok, but still they do not show in Hugo. Also I can see that not all SCSS is behaving the same (pls see image) there is a wider area for our header text on the production server.

The site is now viewable at it’s final location https://valo-liitto.fi and the repo is still at https://github.com/sakumatto/kehitysliitto/
Screenshot 2022-01-17 at 9.53.10

Do you have any suggestions where to look? Does Hugo have specific requirements for Apache that I should know about?


https://github.com/sakumatto/kehitysliitto/ → 404

Sorry, I forgot to make it public again. Should be visible now.

Your site config:

baseurl = ""

Change to:

baseURL = "https://valo-liitto.fi/"

I run it with the version (76.4) that the theme maker seems to prefer and following compile code
hugo_extended_0.76.4_macOS-64bit/hugo --gc --minify --buildDrafts=false --baseURL="https://valo-liitto.fi/"
It is my understanding that by doing this I get the right result?

Yes, by setting the baseURL flag on the command line you are overriding the site configuration file. You can do it either way, regardless of what the theme maker “seems to prefer.” So this is not relevant to your problem.

When I use the browser’s dev tools to view your site:

For example:
https://valo-liitto.fi/icons/caret-icon.svg → 404

You might check your permissions on the server. The apache user (on Ubuntu that’s www-data) needs to be able to traverse to the directory and read the file.

1 Like

Thanks for you kind efforts. I am dumbfounded by this. I have tried to chown the directories to www-data, no help, I’ve also checked the icons that show as 404, and when I do an ls on them, they are there and they are readable, eg.

ls -la www/icons/mail.svg
-rw-r--r-- 1 saku saku 2076 Jan  2 17:50 www/icons/mail.svg

This is very confusing.

I would expect to see permissions like:

-rw-r----- 1 saku www-data 2076 Jan  2 17:50 www/icons/mail.svg

And for directories:

drwxr-x--- + 5 saku www-data 4096 Jun 19  2020 www/icons

If you need additional help with Apache, please try Stack Exchange or similar. We’re off topic here.

Quite right, I do not want to go to Apache questions here, either. But just if someone were to read this later on, I want to make it clear cut that it is not a user or group permissions issue. If it were, the rest of the site wouldn’t load either, as the ownership is consistent over the whole site.

But given the above, it is a pickle why the problem is present.

Here is the weirdest thing. As it seemed that no images from under icons/ were loading, I mass replaced in public all instances of icon/ with an exact copy of said folder ikonit/ and now the site works.

Why this is so, I do not know. Thanks to @jmooring for your gracious use of your time to help me!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.