Can't find the 64bit .deb file to download?

It was Aug 2022 since I last downloaded Hugo as a .deb (64 bit for Linux). Seems things have changed now. All I can get is the , which contains a file called ‘hugo’. No .deb file to be found.

I have had a quick look at Linux | Hugo , however for the Debian section, and Ubuntu, the version is quite old. - 0.92.2-1

This is what I have now …

hugo version
hugo v0.101.0-466fa43c16709b4483689930a4f9ac8add5c9f66+extended linux/amd64 BuildDate=2022-06-16T07:09:16Z VendorInfo=gohugoio

Is there a Hugo extended , version 0.111.1 available as a .deb for Linux 64 bit please ?

There are 4 deb files there.

1 Like

@jmooring - Thanks. My docs on installing had the following from last year.


yet part of the version output has “linux/amd64” . There is no

The version that I have now, when viewed at Release v0.101.0 · gohugoio/hugo · GitHub , has both the .deb files:

yet the latest at Release v0.111.1 · gohugoio/hugo · GitHub doesn’t have either ?


1 Like

Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Address sizes: 39 bits physical, 48 bits virtual
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Vendor ID: GenuineIntel
Model name: Intel(R) Core™ i7-4510U CPU @ 2.00GHz

It’s Intel , not AMD, plus it’s not ARM64 but known as X64 . After that version last year, the .deb files for Linux X64 seem to have disappeared.

Later, …oh they are at Release v0.102.3 · gohugoio/hugo · GitHub but not Release v0.103.0 · gohugoio/hugo · GitHub , so I assume version 0.102.3 will have to do for now. (Until the riddle is solved).

There was a bug at Asset hugo_0.102.0_Linux-64bit.deb has files in wrong location · Issue #10220 · gohugoio/hugo · GitHub , and then soon after the hugo_*******_Linux-64bit.deb files appear to have vanished.

You are confusing brands with architectures.

You want this one:

1 Like

@jmooring - Thank you, That worked just fine. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.