Academic Theme: Trouble Getting Metadata to Show


  1. I am trying to get metadata in my posts to show up. For example, lastmod and reading_time metrics to show at the top in my posts. I am using the Academic theme, and I took one of the example pages and used it here:

I can see two dots underneath my username (middot-divider). This page was copied directly from the theme’s example site, and lastmod was already given a value of: lastmod: “2019-04-17T00:00:00Z”. Additionally, my enableGitinfo is set to true, along with reading_time = true in my params.toml.

  1. I am expecting that the metadata in my posts show up considering I have either a manual value entered in the front matter or enableGitInfo set to true in my config.toml.

  2. As I can see here: the metadata doesn’t seem to show up, and I only see two alone middot-dividers beneath my username.

I am using the Academic theme for Hugo, hosted on Netlify. I have the same issue when running locally. I am developing on Ubuntu through Windows Subsystem for Linux.

Any ideas or perhaps a configuration setting that I missed? Thanks!

Please follow the advice in the requesting help message. You’ll need to share your site project. :slight_smile:

Also, check the Academic theme support resources; they had a dedicated issue queue and chat support.

Hello, the project can be found here:

I’ve already made a post over at the Academic support site. :slight_smile:


After examining the documentation more closely: the directory structure of Academic/Hugo is very important.

Academic uses “posts” content types with this kind of meta data. My own custom pages need their own content type with the metadata structure.

A little more time in the documentation helped. :slight_smile: