Weird behavior: markdown file copied to /public instead of created as html


#1

We’re observing a weird situation today with our hugo builds.

Situation:

We copied an existing markdown file from our site, into a copy with a new filename (file is in the same directory, has identical frontmatter, etc), and changed content - including the title in the front matter. So, we expected a new html file to appear in /public when we ran hugo, but instead, the markdown file itself appeared in the appropriate place in the file hierarchy in public and no html file was generated. We cleared /public several times and the behavior recurred when we re-ran hugo.

We’re using hugo .51 on osx, but the same problem was observed on Netlify (ubuntu 14.04) with hugo v .0.37.1 as well as v 0.51. We don’t use the extended version that handles SCSS and the like.

Using hugo -v during the build does not say anything special about the file.

It’s the second file in this PR, in case you want to check it out:

As you can see, it’s pretty basic and the frontmatter was ripped off from a file that works well and is in the same directory (the other file that was modified, and whose changes did get built into /public as expected).

Just to save you a tri pto github, this is the front matter for the file:

---
title: "Shift and Zoobomb history"
date: 2017-11-20T20:20:00-08:00
draft: false
weight:
---

Never seen this behavior before but betting someone else has, so I come to you for advice, gurus.


#2

Well, we don’t understand why this fixed it, but this commit caused things to start working right locally and on Netlify:

Looks to me like all it added was a trailing newline, but some of the metadata (“type”) on OSX was changed to “TEXT” from the old value of \0\0\0\0. I don’t see that git tracks that info in any way, so mystery not solved or explained, but worked around at least. Spooky!