Upgraded and lost all of my tags?

I suspect I need to update configuration or something. My blog is at https://github.com/frioux/blog ; you should be able to check it out and build it to see my issue.

I’ve been using 0.22 for ages and recently saw the addition of non python syntax highlighting so I went ahead and upgraded. Unfortunately I found that my tags no longer get created! With version 0.32 I get ./public/tags/vim/index.html, with version 0.33 that file is never created.

I saw that indexes was removed, so I made this change to my config but it still doesn’t create the tag files:

   name: "Arthur Axel fREW Schmidt"
   twitter: frioux
   tag: 'tags'
 baseurl: 'https://blog.afoolishmanifesto.com'
 canonifyurls: false

I rolled back to 0.22 but would love to be on a modern version; can anyone help?

It’s baseURL not baseurl also it’s canonifyURLs not canonifyurls

See: https://gohugo.io/getting-started/configuration/

And for taxonomies: https://gohugo.io/content-management/taxonomies#configure-taxonomies

If I try your repo, I get the same problem that the individual tag pages don’t render. But it gets fixed when you copy /layouts/indexes/tag.html to /layouts/_default/tags.html. Then the tag pages render properly.

I don’t know what happened with the template order with Hugo 0.22 versus 0.41, but it seems you’ll need to change the lookup order for taxonomy terms.

1 Like

I tried your suggestion @Jura and it doesn’t seem to have made any difference. I pushed the change to a branch in the repo called modern-hugo (https://github.com/frioux/blog/commit/eedce53a211d7106c0eb3d07ca7c30b44e94c10e), in case I made a dumb mistake. I’m looking at the lookup order now to see if maybe I am misunderstanding something.

Aha, I needed to put the file in layouts/_default/tag.html (singular, not plural.) Thanks for the tips!