Unify page kinds and default layout names

It’s confusing that Page.Kind can be page, home, section, taxonomy, and term, but the corresponding names for these in layouts/_default are single, home, list, taxonomy, and term. Specifically, page != single and section != list.

We have enough page concepts floating around already (HTML pages, Hugo pages) that it’s confusing to call the kind of single pages page.

It would be nice to unify the terminology with clear terms. Let “page” be an abstraction, and let kinds be specific types of pages.