Some of my tags doesn't work

#1

I’m using Hugo v0.49.2/extended darwin/amd64 BuildDate: unknown.

I have some problem on my tag setting. I’m writing hugo blog for my Japanese blog.

On local, hugo server, every single tag page showing correctly. But once I published, some of my Japanese tags returned 404 pages. Not all Japanese, but a few of them. I compared generated html by hugo, but it looks like completely same except url decoding part.

To solve this problem. which part should I start from?

Thanks for your help.

#2

Odd, are you seeing this same 404 phenomenon for other katakana tags? Conversely, are all the hiragana tags working? Is there a difference adding the trailing slash, or not?

Can you try deleting all the content on your server once and re-uploading? I had a problem like this before, where I was using rsync to upload, but I did not have it set to overwrite.

Regards
Rick

#3

Well, I can find this kind of problems for some of Japanese tags which includes katakana, hiragana and kanji.

I can not find specific rule for this until now.

No, there are no difference even though I add trailing slash.

Ok, I’ll try your suggestion and I’ll let you know what happen. Thanks for your help.

2018/10/26 18:22、Rick Cogley gohugo@discoursemail.comのメール:

#4

Not sure how you’re getting your site uploaded, but, if you happen to be using rsync on Mac, like I do for some of my sites, the command I use is:

/path/to/rsync -avz --delete --iconv=UTF-8-MAC,UTF-8 --exclude '.well-known' /tmp/mysite/ myuser@remote-web-host.com:/home/myuser/path/to/mysite/

FYI

1 Like
#5

I tried deleting all contents and re-uploaded, but I still have same problem here. What should I try or check next?

#6

We’d have to see your repo I think. Please have a look at Requesting Help and provide some more details? Thanks.

#7
Hugo Static Site Generator v0.49.2/extended darwin/amd64 BuildDate: unknown
GOOS="darwin"
GOARCH="amd64"
GOVERSION="go1.11.1"
git version 2.15.1 (Apple Git-101)

This is my environment.

Unfortunately, I’m not familiar with tech. So I broke up my repo in these days somehow. I’m not sure what should I donow.

Maybe I had better leave hugo and return to wordpress…

Well, anyway thanks for your kind support. I appreciate.

#8

ok, can you make a github gist, include some of your files and share it? I want to see your config file, and the relevant templates. It’s hard to help if we cannot see what is actually going on.

#9

I really appreciate your kindness support.
I made gist as below.

Is this including what we need to solve problem? I copied config.tml and partials/tags.html.

Thanks again.

#10

Ok, one thing I noticed - in your config, you have baseurl but, in the docs it mentions baseURL. It’s best to err on the side of caution and spell it exactly like you see in the docs. I can’t say if this is just superstition or not, but it could have an impact.

#11

Another thing off the top of my head, is the post that has アンチパターン or other tags that cause a 404, set to draft = true?

In addition, you can see any errors if you run hugo server with the --verbose tag. Are you seeing any useful errors that way?

#12

First, I tried changing to baseURL, but nothing changed.
Second, draft was not set.
Third, I was not able to find any error with --verbose. Only I can see was some warn.

WARN 2018/10/29 08:34:37 No translation bundle found for default language “en”
WARN 2018/10/29 08:34:37 Translation func for language en not found, use default.
WARN 2018/10/29 08:34:37 i18n not initialized, check that you have language file (in i18n) that matches the site language or the default language.

I guess this is nothing to do with tags problem.

Only the cause of this tags problem came up to my mind through trouble shooting this time is “hugo version”. I updated hugo version before from 0.2x to 0.4x. I guess this cause problem. So I’ll compare the content file before updating and after updating.

Anyway, I appreciate this community:D
After comparing the content files, I’ll post update.
Thanks again.

#13

Do you know any command I can check when I updated hugo’s version? I installed hugo with homebrew.

#14

Yeah, maybe so. A lot has happened from then to now. The Icarus theme might also be out of date in some respect - you might check with its author.

If you can’t make a repo, then you could zip up all your project files, and copy the zip to static in your project, and republish. That way, someone could download your zip, unzip, and run Hugo on the folder to test.

#15

Thanks a lot!!!
Finally, I could send my repo to github.

Well, anyway. I’m going to keep troubleshooting.

#16

Hmm. For regular software you can get install history by option-clicking the apple menu, then going to Software, then picking Information. But for homebrew, it appears there’s no easy way to find the update history (hope i’m wrong). You might poke around in /usr/local/Cellar with ls to see if you can see any dates…

#17

Great, I found it.
But by comparing two content files before updated and after updated. I can not find any difference.
I’ll contact theme creator next.

#18

Could it be something about how you’re uploading? Assuming you can find the index file for the アンチパターン tag or other 404-ing tags, in public after you run hugo to generate, can you get a verbose log from whatever it is you’re using to upload? Maybe it is hanging on certain tags, for some reason…

#20

Well, I’m using forklift to upload, I’ll check how to see my log! Please give me a moment.