[Solved] Missing pages on site build/hugo server


Hugo is great, but right now, when I run hugo server several pages 404 unless I change the file. Then live reload seems to kick in.

When I run hugo most of the time a number of pages are missing in the /public directory.

I’m on hugo 0.37.1 installed via homebrew running under macOS 10.13.3 .

Here’s a link to the entire project (including theme): https://www.dropbox.com/s/6ph0epetzt3jlmq/linkless.org.zip?dl=1

Forgive the zip, but I don’t want it on github just yet.

Just in case it helps, here’s my config.toml:

baseurl                 = "/"               # Your domain name. Must end with "/"
title                   = "Tyler Spaeth"
theme                   = "sam"

    dateform            = "Mon Jan 02, 2006"
    dateformfull        = "Mon Jan 2 2006 15:04:05 EST"
    favicon             = "/sam.ico"
    pygmentsStyle       = "monokai"                     # https://help.farbox.com/pygments.html
    pygmentsCodefences  = true
    homepage            = "Main"                        # What to call the home page link
    galleryFolder       = "images/"                     # Where you've put your images, after "/content/gallery/"
    clickablePhotos     = true                          # Allow links to the full size images
    footerText          = "Call me Sam, a theme for Hugo."

# Metadata
    description         = "About Tyler Spaeth"            # Max 160 characters show in search results
    twitterCard         = "summary_large_image"         # Card value “summary”, “summary_large_image”, “app”, or “player”
    primaryImage        = "/avatar.png"                     # Image that shows on Twitter cards and OpenGraph links

    link = "/posts"
    text = "Thoughts"

    link = "/portfolio"
    text = "Portfolio"

    link = "/about"
    text = "About me"

The pages that 404 are generally anything other than the home page. Note I was able to get it to build and upload to linkless.org with all the content intact. But I have no idea why it worked then and not otherwise.

I’ve searched the forums and github issues with no luck.

Any help is greatly appreciated.

(PS: if the formatting is off, my apologies, I didn’t see a preview function.)

Finally figured it out. I had a file called index.md in my content directory. Apparently that was bad news. I removed it and the problem went away.

Yep. For context, have a look at: