404 when deploying to gh-pages

Hi, I’m trying to host a site with gh-pages following the official guide but although it deploys, it isn’t here where I would expect it to be. It’s probably some silly mistake on my part but I can’t find it.

This is the corresponding repo. All help will be greatly appreciated.

I cloned your repo and theme and when did hugo serve locally also got 404 page not found hence don’t think its GitHub Pages issue. You need to look at local development first.

Interesting, my local server works without any issues. I’m running hugo 0.101.0-1 on Manjaro Linux, can there be any problems with compatibility?

I run into the same problem when trying to publish the site you get by following the quickstart guide (repo)

Here is the output of hugo serve on my machine with all pages being accessible

Start building sites …
hugo v0.101.0+extended linux/amd64 BuildDate=unknown

                   | EN
  Pages            | 11
  Paginator pages  |  0
  Non-page files   |  0
  Static files     | 79
  Processed images |  0
  Aliases          |  2
  Sitemaps         |  1
  Cleaned          |  0

Built in 37 ms
Watching for changes in /home/liesk/Dropbox/Notes/{archetypes,content,data,layouts,static,themes}
Watching for config changes in /home/liesk/Dropbox/Notes/config.yaml
Environment: "development"
Serving pages from memory
Running in Fast Render Mode. For full rebuilds on change: hugo server --disableFastRender
Web Server is available at http://localhost:1313/Notes/ (bind address
Press Ctrl+C to stop

When you visit https://github.com/lieskjur/Notes/settings/pages does it look like this?

It did not. Thank you, everything works now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.