[SOLVED] About page not being generated for GitHub Pages


#1

I’m running Hugo via git and it’s generating most of my site without any issues. However, the about widget isn’t being generated and slotted in, where appropriate. I’m very new to Hugo; I’ve spent several hours trying to figure this out but I’m stuck and have no idea how to fix the issue. Help would be most appreciated.

GitHub repo: https://github.com/arcaravaggi/arcaravaggi.github.io

hugo env

Hugo Static Site Generator v0.49 windows/amd64 BuildDate: 2018-09-24T10:01:53Z GOOS="windows" GOARCH="amd64" GOVERSION="go1.11"

No warnings evident via hugo -v

I’ve read other, similar threads in the forum but didn’t find an answer to this specific issue. I’ve also compared my files to another Hugo-based site https://github.com/sdundon/sdundon.github.io and there are clear differences. Her ‘about’ section is rendering, for one.

Edit: Original files can be found, here.


#2

Hi - not sure what you meant to say, because you mentioned github pages in the title but “git bash” in your message. We need some more info to be able to help you, so please have a look at Requesting Help and provide some more details? Thanks.


#3

Hi Rick. Apologies for the lack of detail. I’ve updated my post, accordingly.


#4

It seems these files you are posting are the files generated from hugo not the actual source files, without those we can’t help you debug what is going on.

Is your about page in draft mode? is in under the content folder? You need to put your source files in git so we can see what is going on.


#5

Thanks for the response. I’ve uploaded the source files, here.

Not the ideal archive method, I know, but I’m having issues with my home laptop (site was built, generated and uploaded in work).


#6

You have a future date in your about page. Thats why it doesn’t render.

# About/Biography widget.
widget = "about"
active = true
date = 2018-10-20T00:00:00

#7

Oh my. Excuse me while I facepalm. I’ll edit and re-render and report back, no doubt to acknowledge my idiocy.


#8

Yep, that worked. Of course. Thanks for your help and patience, it’s much appreciated.


#9

The problem was caused by a date stamp that was set to a future date. Simple, but something I clearly completely overlooked. Many thanks to both responders for the help and patience.


#10

No worries, it happens :wink: