Site suddenly cannot render anything and page not found

My site has been created for a month and I’ve never had this problem before. I changed and some markdown files and menu name in the config.toml today, and the secondary page suddenly have nothing rendered. For list page there is just a blank page and the console shows nothing, but an issue “Page layout may be unexpected due to Quirks Mode”. I checked the HTML file in public folder and the tag exists. For single page there is a 404 page, the console show “GET localhost:1313/about/ 404 (Not Found)” also checked it does exist. If I just type the url like “localhost:1313/posts/xxx/” in the address bar, it will be a 404 page. The index page is fine though.

When I use command hugo or hugo -t -theme_name, it seems nothing wrong, the site is built, the number of pages is correct. And I also tried hugo server --disableFastRender and hugo server -D, both are no use, the browser still shows nothing in second directory page. And I’ve trid a different browser, tried upgrading hugo ( I used 0.85.0 version when I built this site), even tried git reset --hard to the last commit, the problem is still there.

I use GitHub page to host this site. After I push this problematic code into GitHub repository, the result is more interesting. At first the index page is the version I just modified, but once you clicked on the button which linked to the secondary page, it suddenly change into the former version. I’m so so confused! Please any ideas?


This is the change the broke your site:

Thank you so much!!! it works now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.