Problem migrating from Forestry CMS to Tina CMS

Hello everyone. I am trying to migrate to Tina CMS and it keeps giving me the same error. Please help.

When executing:

 npx @tinacms/cli@latest init

Going through this process:
:heavy_check_mark: What is your Tina Cloud Client ID? (Hit enter to skip and set up yourself later)
Don’t have a Client ID? Create one here: Tina Cloud … (ID inserted)
:heavy_check_mark: What is your Tina Cloud Read Only Token?
Don’t have a Read Only Token? Create one here: Tina Cloud … (token inserted)
:heavy_check_mark: Choose your package manager › NPM
:heavy_check_mark: What framework are you using? › Hugo
:heavy_check_mark: Would you like to use Typescript for your Tina Configuration (Recommended)? … yes configuration found.
:heavy_check_mark: Would you like to migrate your Forestry templates?
Note: This migration will update some of your content to match tina. Please save a backup of your content before doing this migration. (This can be done with git) … yes
{ frontMatterFormat: null }
:heavy_check_mark: What format are you using in your frontmatter? › yaml

I get this error:
Error parsing template frontmatter template’, tem + ‘.yml’
ZodError: [
“code”: “invalid_type”,
“expected”: “number”,
“received”: “string”,
“path”: [
“message”: “Expected number, received string”
at get error [as error] (/Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/zod/lib/types.js:43:31)
at ZodObject.parse (/Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/zod/lib/types.js:141:22)
at parseTemplates (/Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/@tinacms/cli/dist/index.js:3402:46)
at getFieldsFromTemplates (/Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/@tinacms/cli/dist/index.js:3392:20)
at /Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/@tinacms/cli/dist/index.js:3454:39
at ()
at generateAllTemplates (/Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/@tinacms/cli/dist/index.js:3452:30)
at async generateCollections (/Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/@tinacms/cli/dist/index.js:3651:23)
at async forestryMigrate (/Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/@tinacms/cli/dist/index.js:3980:59)
at async initStaticTina (/Users/paloma_chiara/.npm/_npx/b34d1f235ac7f645/node_modules/@tinacms/cli/dist/index.js:3809:17) {
issues: [
code: ‘invalid_type’,
expected: ‘number’,
received: ‘string’,
path: [Array],
message: ‘Expected number, received string’
addIssue: [Function (anonymous)],
addIssues: [Function (anonymous)],
errors: [
code: ‘invalid_type’,
expected: ‘number’,
received: ‘string’,
path: [Array],
message: ‘Expected number, received string’
Error occured during tinacms init

Here is the code:

Thank you in advance

Best guess… remove the single quotation marks around these integers:

In the future, please raise your questions here:

Thank you, that solved it…
I just have one more question, tinaCMS seems to be set up,
but when I go to my site/admin/ ( /admin/), it shows blank,
I’m thinking it could be an issue with the build command,
I’m using “tinacms build && hugo” (as the build command in Netlify and also in the package.json file). Any thoughts ? thank you

See my previous reply:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.