OT: Netlify admin/config.yml not found

I enabled Netlify Identity and CMS on my site and set up admin/index.html and admin/config.yml and everything worked. Yay!
I then edited the config.yml to change the images folder from ‘static/images/uploads’ to just ‘static/images’. I don’t see how this is connected, but immediately afterward Hugo says this:

‘Syncing admin/config.yml to /’

And I can’t access mysite/admin anymore:

Error loading the CMS configuration
Config Errors:
Error: Failed to load config.yml (404)
Check your config.yml file.

Why would Hugo be putting admin/config.yml in /?

Did you restart or stop and start the hugo server while this all happened?

Not sure. I might have? Why? What do you think might be going on?

Sometimes Hugo does not “see” new or changed folders while running. After a new start it should work.

I had the ‘admin’ site on the published site working though and now, for some reason it doesn’t. I’ll try restarting hugo on my machine, but that doesn’t explain why the Netlify site is messed up.

OK. This solved it for me.

Netlify CMS config.yml Not Found

I don’t think this is a Hugo problem. I needed to tell Netlify to find the config in admin/config.yml by putting:

in the of the netlify admin index.html

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.