Option to disable LaTeX style dash parsing

The configuration page offers a number of options for adjusting Blackfriday.

One that seems to be missing is disabling LaTeX style dash parsing. Taken from the Blackfriday docs:

LaTeX-style dash parsing is an additional option, where – is translated into –, and — is translated into —. This differs from most smartypants processors, which turn a single hyphen into an ndash and a double hyphen into an mdash.

I left Wordpress to get away from the renderer hijacking dashes, so if there is currently an option to disable this behaviour please educate me! All I would like is two dashes to display two dashes. That’s all, no fanciness, no nothing. Just two dashes :slight_smile:

If not, I plead humbly at your feet to implement a toggle option for this setting.

I swear when I can code (I’m learning) this will be my first pull request if it’s not done by then!! :smiley:


I’m pedantic about some of these options myself.

Can you create an issue at https://github.com/spf13/issues

There is a similar request in there somwehere, so it would be quick to take them both in one go.

Issue added:

This is now added to the latest source.

Excellent, thank you!