Not showing blog posts after upgraded to 0.69

Hey, after I think 4 hours I gave up, I need your help.

I upgraded hugo (from 0.54 to 0.69) and I can’t find solution for my problem. It’s problem with Dopetrope theme
I try with a fresh theme and I have this problem.

On the main page it’s not showing blog posts (also only show „blogs” post) but on the page http://localhost:1313/blog/ its display posts correctly.

Can anybody help to find a solution? I would like to show this problem on a server but it’s strange, when i run the command hugo its not showing correctly from the public directory, on localhost you can see the problem, so I attach the whole directory. http://jj.ct8.pl/dopetropehugo/hugodopetrope.zip

There’s been some changes to how .Pages behaves. You probably want .Site.RegularPages

can anybody help with this? I tried but still get errors

See Demos with empty homepage and/or wrong posts list · Issue #682 · gohugoio/hugoThemes · GitHub for a detailed fix of what you describe.

If you still have problems then you need to share your repo in the forum.

Thanks for help @alexandros but I tried again for few hours, I can’t do it without help from community.

I uploaded both versions to show differences

  1. hugo 0.54
  2. hugo 0.72

Screenshot with differences between 0.54 and 0.72
I prepered also with whole directory (download) with content to run with command
hugo server -w -v --disableFastRender

Additional: official repo for this theme

Does anyone could help with that?