No Theme or Images in Generated html files


I am sure I am doing something very fundamentally wrong, I apologise for that. I have searched the forum, but maybe used the wrong words, as I can’t find this, but…

Background Info:

  • My first time doing this.
  • I have a basic site which looks fine on my local “hugo server”
  • Hugo Static Site Generator v0.74.3-DA0437B4/extended linux/amd64 BuildDate: 2020-07-23T16:30:30Z
  • Theme hyde-hyde (

I tried to build the html files following the instructions here:

My site was working with “hugo server”, stopped it “Ctrl+c” then ran “hugo” to build the files in ./public

All good, it generated files.

But the files do not have any template, just the text I put in from my content. It doesn’t appear to have generated the pages using the theme at all. When I look at the files in my browser, I just get text, no theme and no images (not even the ones that I added to my pages) - just these, Linkedin and the date, tags and how many minutes read:


So, what on earth have I done wrong/not done right?

Thank You

“theme not rendering” is what you want to search for. This is actually a very common issue. Have a look inside your config.toml and look for

baseURL = ""

On the right side you add the full proper path to your website. Don’t forget the slash at the end. If is still does not work then post a link to your repository and website to check what’s happening.

@davidsneighbour - thank you.

Yes, I was searching for the wrong words.
Yes, your solution works.

I am deploying on a local development webserver at the moment, with a funny configuration for sites, but I worked out the syntax for my base URL in the config file. All is good now, appreciate your help.

I should be good to correct the URL just fine now when I deploy live.

I think Hugo ignores that parameter locally (that’s why it’s working locally, but not online). It’s only for the deployed site in public, so you can change it right now to the proper URL(s).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.