HUGO

MIME type ('text/plain') is not a supported for font-awesome.min.css

Hello!
I’m building up my portfolio, and I keep running into this error:
Refused to apply style from 'http://localhost:1313/plugins/fontawesome/css/font-awesome.min.css' because its MIME type ('text/plain') is not a supported stylesheet MIME type, and strict MIME checking is enabled
On the actual website, it just claims a 404.

I tried removing the comment on the top to no avail, and none of the other answers online seem to be working with Hugo. My repo is here: https://github.com/jessica-jorgenson/website
Thanks!

the file in static dir name fontawesome.min.css not font-awesome.min.css

change it in your config.toml:

[[params.plugins.css]]
++link = "plugins/fontawesome/css/fontawesome.min.css"
--link = "plugins/fontawesome/css/font-awesome.min.css"
3 Likes

Thank you! Thought this would fix the icon issue, but apparently not. Tried updating the FontAwesome folder and such (changing fa to fas) but no bueno. Do you see what’s happening there?

Thanks again!

looks like, you need to add it manually, because there are some iconsets you can choose here regular, solid, brands, and all to load all iconset.

[[params.plugins.css]]
link = "plugins/fontawesome/css/solid.min.css"

but i found problem, where the DOWNLOAD MY RESUME Button icon doesnt work, then i check the source in static/plugins/hover/hover.css.

i found that the button using font-family: FontAwesome instead 'Font Awesome 5 Free'.

so you need to replace it all

++font-family: 'Font Awesome 5 Free'
--font-family: FontAwesome

then everything works.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.