Localhost version not displaying

Hi, I’ve a new macBook Pro with OS Sierra (10.12.4). I’ve installed Hugo (via homebrew) and cloned a site my company is putting together from Github. I run the hugo server --buildDrafts command and then go to localhost:1313/docs (as we have specified) and I get nothing. So I tried with the Bookshelf site and got the same. Is it possible I have a configuration issue I’m not aware of?

Yes, but I’ll need a bit more to go off of. Can you point me to the repository? Before that, do me a favor and open your dev tools in the browser and see if you’re getting any errors…

It’s difficult to say w/o having some kind of code to look at.

@Hash_Borgir If I had any browser code to show you I would. This is the problem. I’ve attached a screenshot of the console output.

@rdwatters Unfortunately the repository is private. I’ve now attached the console output.

As @rdwatters mentioned, it would be best if we could look at the whole source in a repository. Please link us if able. Thank you.

@marksouthee Next question is whether you’re getting anything in the terminal when you run hugo server. If nothing there, I’ll have to take a look at your source, please :smile:

@rdwatters Output from hugo server below. Note that the ‘*’ in descriptions and a couple of paths are just to disguise the project name :slightly_smiling:

WARNING: Site config’s rssURI is deprecated and will be removed in a future release. Set baseName in outputFormats.RSS.
Started building sites …
ERROR 2017/04/10 16:24:41 Two or more menu items have the same name/identifier in Menu “main”: "With ***".
Rename or set an unique identifier.
ERROR 2017/04/10 16:24:41 Two or more menu items have the same name/identifier in Menu “main”: "With ".
Rename or set an unique identifier.
Built site for language en:
0 of 1 draft rendered
0 future content
0 expired content
279 regular pages created
54 other pages created
0 non-page files copied
0 paginator pages created
0 tags created
0 categories created
total in 735 ms
Watching for changes in /Users/marksouthee/
Serving pages from memory
Web Server is available at //localhost:1313/docs/ (bind address

Hmmm. The menu error shouldn’t be keeping the entire site from rendering. And I’m assuming you have a baseurl of yoursite.com/docs, yeah? If you want to invite me to the repo to take a look, I might be able to help, otherwise it’s all a stab in the dark.

It’s also interesting that you’re running the hugo server --buildDrafts command it says 0 of 1 drafts is being built. Are none of the pages loading up?

Also, how far along are you in this project? That is, was this site up and running without issue on local dev before you just cloned it? I assume it’s been running for a bit if you have hundreds of pages…

@rdwatters Two other people in the office have it running ok (both on the same version of Mac OS). The fact that the Bookshelf demo also won’t run seems to point at some issue on my machine. I’m going to try on another mac when I get home tomorrow.

1 Like