HUGO

Issue in the B/W on Fuji-2 theme

I have been using the Fuji-2 theme for my website hosted on Netlify.

I have enabled the Black/Dark theme on the page, but it is not consistent. I agree, when it viewed on other users’s machine it gets loaded in the white color theme. But in my own machine, at times it changes to white theme.

How do I enforce to use the Dark theme always? I really feel the Dark theme is more appropriate for this Fuji-2 theme. Any help would be highly appreciated.

Cheers,
RM…

Have a look at the theme’s exampleSite config: hugo-theme-fuji/config.toml at master · dsrkafuu/hugo-theme-fuji · GitHub

Thanks @pointyfar . Let me take a look and update.

Hello @pointyfar , the link you provided was of a great help and I did make a few other defaults other than just the theme. However, I have an issue with the site given by Netlify where it does not really seem to reflect the dark theme as configured below in the config.toml file.

[params]
  defaultTheme = "dark" # default theme when first visit (auto|dark|light)

Can you please help me understand what would be the reason for this gap? Also, you can check my personal/custom domain hosted on Netlify as well once and confirm whether you are able to see the dark theme.

The reason being, I tried testing in a few different browsers but I always get to see a dark theme but my friend told me that he was getting only a white theme - a few days ago. That was the main reason for this post in Discourse Forum. Thanks for your understanding.

[Update] I had actually used a browser inside a VM to check this settings due to the suspect of the browser cache. After making this post, I hard reloaded the page (crtl+F5) and this seemed to take an effect :slight_smile: If possible you can just check and confirm from your side - it will be of a great help and an additional source of verification. Thanks a lot for your help!

Cheers,
RM…