Hugo v0.15 hugo server does not return anything

Hi everyone!

I am using the latest version of Hugo on a Windows 7 Machine with Cmdr as command line.

When entering the command “hugo server” I get a blinking cursor and not the standard response with the amount of pages generated and the localhost:1313 info.

The “hugo” command works fine and returns:

λ hugo
0 draft content
0 future content
3 pages created
0 paginator pages created
1 venues created
1 bands created
in 131 ms

Am I missing something?


Hi, Bep.

Thanks for your response. I am working on a 386 system and using the “32-bit only” version of Hugo.

Any other possibility ?

Do you use Avast antivirus? If yes, have a look at the bottom of this:

I am using AVG free.
Tried to add Hugo to the exclusion list and also to disable AVG.

Alas, to no avail.

I tried : $ hugo server -v
it stops at:

INFO: 2015/12/09 Using config file: C:\Website\CastilloSingsNew\config.toml
INFO: 2015/12/09 syncing from C:\Website\CastilloSingsNew\static/ to C:\Website\CastilloSingsNew/

Hi all!

I have the same behaviour in ubuntu 14.04 (32 bit).

Just followed the same steps from the video “A New Hugo Site in Under 2 Minutes”.

Any idea about what could be?

Try running the server with --renderToDisk=true. It seems like Hugo v0.15 32-bit has problem rendering pages from memory on some platforms. I had the same problem with a 32-bit debian based distro and Hugo.

It worked! Thanks a lot!