Hugo server website correct; deployed website missing content

Using hugo 0.48 and airspace theme to hack up a website. Everything works as advertised with hugo server. But when deployed some content is missing. Forgot to add newbie alert.

Website is here:

Clicking on blog renders correct global header but no contents. As mentioned works fine on hugo server.

Here is the repo:

Can’t figure out what is going on. Any guidance much appreciated.




You have your blog entries set to draft = true.

Thanks for the guidance to check the blog front matter. On local server it behaved as expected (i.e. when draft = true, hugo server (no -D) would not render. In Netlify deploy it still did not work.

I noticed additional front matter material in blog content. I removed it so it matched up with front matter formats in other rendered content entries (i.e. just title and type).


Wondering if there was something in netlify toml? For example HUGO_VERSION = “0.47.1” in the netlify toml instead of the “0.48” that I am using.

tx again


As @pointyfar mentioned, did you change your drafts to false?

If, for some reason, you wish to keep them as drafts, you can still deploy them by updating your netlify.toml build command:

command = "hugo -D"

Yes, tried draft = false in front matter of blog content but still did not render in netlify deployment. But it behaved correctly using hugo server.

Was thinking netlify for some reason, when it saw the draft variable in the front matter, treated it as draft = true. I removed the draft variable from front matter and it worked.

Will try command = “hugo -D” if this occurs again.


Probably good practice to use the same version of hugo for testing and netlify production - so do change from 0.41 to 0.48 in netlify.toml

And I’ve not had problems with netlify and the drafts variable in front matter. My guess is that maybe something else meant that your site didn’t rebuild when you set draft=false.