Hugo ignores single.html for posts

I’ve added a single.html to my /layouts/posts/ folder in the theme. Nevertheless, all my blog pages (with “type” also set to “post”) are rendered using the page.html template from the partials folder.

Did I miss something? How can I make Hugo use the post-single.html file for rendering?



You need to enter the final s in your type parameter for the template to be picked up.

If the above does not work, then you will need to share your project’s source code.

1 Like

Yeah, that’s the mistake. Added the trailing “s”, now it loads the correct template…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.