Hugo-git v0.34.r27.g4eb2fec6-1 broke will see if v0.31.1 will handle it now

The site was created with the theme from Yoshiharu Yamashita

I thought at first that this had something to do with the theme itself, but I was wrong.

The latest version (or close enough to it) of Hugo, - pardon my poor knowledge - just broke the side menu links that the theme provided

It made little difference how the config.toml was handled.

I will see if I can somehow download 0.31 and go from there.

The site was created by following the same procedures than before.

I noticed the issue by clicking the Posts from the root directory. The posts were simply not there.

On one hardware sluggish system I use, v0.31 was working flawlessly, compared with the other system where I normally work at.

I wanted to get to the bottom of it, and lo and behold, as soon as I upgraded, it broke the other end. Then again, I wanted to make sure it was not an issue with the theme blackburn itself.

The config.toml was created first how i normally have it, mainly with the side menu entries of the theme blackburn, Then even with minimal settings

baseURL = ""
languageCode = "en-us"
title = "My New Hugo Site"
theme = "blackburn"

it was working correctly under v0.31

Thanks for any advice

Edit: Please, notice that I also compiled the latest version with
go get -v

and updated accordingly afterwards, but it made no difference

the path was also specified accordingly.

Then I tried to downgrade Hugo, by using the package manager from my distro, but it was too late to do so.

2nd Edit: After reading Active Link dosen’t work I’ll try to go over the theme configuration and see if it works. Couldn’t figure out why on an older version worked, while with the newest release didn’t.

3rd edit the theme was downloaded a few times today. But I don’t see recent commits from that repository.

It’s just simply beyond me, that the same code from the theme downloaded this morning (while using v0.31 ) works, while the latest one doesn’t. I just copied the theme from the other directory. Diff unavailable.

I just tested with the latest Hugo and the side menu link works as expected. The theme itself was downloaded quite a few times this morning.

Could someone test that theme for me? I appreciate it.

What is your question? We can help you, if you have an issue. If you have questions about that theme, please ask the theme author, as they will be most qualified to assist. :slight_smile:

maiki, I checked the theme commit history, and it does not show recent updates.

When I downloaded it earlier, I had hugo v0.31. With hugo v0.31 the theme worked fine.

Later with hugo 0.34 the side menu link /post/, as it was suggested by the author of the theme and specified later on the config.toml did not work.

Can you test that specific theme from your end?

We can help you, if you have an issue

Maiki can you test that theme for me. I would appreciate it.

config.toml can be something like the author of the theme suggested:

 baseURL = ""
 languageCode = "en-us"
 title = "My New Hugo Site"
 theme = "blackburn"
   # Shown in the side menu.
     name = "Home"
     pre = "<i class='fa fa-home fa-fw'></i>"
     weight = 1
     identifier = "home"
     url = "/"
     name = "Posts"
     pre = "<i class='fa fa-list fa-fw'></i>"
     weight = 2
     identifier = "post"
     url = "/post/"
     name = "About"
     pre = "<i class='fa fa-user fa-fw'></i>"
     weight = 3
     identifier = "about"
     url = "/about/"
     name = "Contact"
     pre = "<i class='fa fa-phone fa-fw'></i>"
     weight = 4
     identifier = "contact"
     url = "/contact/" 

On the other system, even with the latest Hugo release, the link that points to Posts does not work.

I’ll help test the theme out, but you’ll need to provide a site for me to clone. Check out Requesting Help for a guide on providing troubleshoot information in the forums. :slight_smile:

Also, have you contacted the theme author? If they are actively developing the theme for current versions of Hugo they’ll want to know if their setup directions are not accurate for the latest release. I still think you ought to talk to them about it.

Thanks for your help Maiki.

I have the issue which was just described, on only one machine. There were some updates to webkitgtk2 and other packages. So perhaps that’s what led to the problem.

Thanks again for your help. You can close the post, or remove. Or ask a mod to do so.