How to enable non-ascii URLs?

I know this question has been raised before, but that was years ago. And maybe something has changed.

I ran the quickstart guide for hugo (Quick Start | Hugo) and tried to add a single tag to a post in Chinese. However, while all English tags work, the Chinese one returns a 404. This is all running locally with hugo server

How can I enable a mixed mode where Chinese (or any UTF-8 / non-ASCII) character generates a valid URL?

I also tried different themes, but nothing seems to help. Find it kind of unexpected since I have seen websites with hugo that have CJK urls.


1 Like

Thanks, I thought I was missing something in the config. I spent hours reading through forum posts and the documentation :upside_down_face:

Downgrading to v0.102 worked like a charm

Fixed in v0.103.1.

1 Like