`<head>` section missing in one of the built pages


I have created a new blog using hugo, being served at https://jandot.github.io. The source code is available at GitHub - jandot/jandot.github.io: Saaientist blog 2.0. I use the cactus theme.

Although the site displays correctly on the local machine using both hugo or hugo serve, there are issues when deploying via github-pages. More specifically, the <head> section of the tags page seems to be missing. Result: the tags page is not styled. The other pages do have access to their styles…

Does anyone know why this could be? I’m pretty versed in jekyll, but new to go and hugo.

FYI, hugo env returns:

hugo v0.101.0+extended darwin/amd64 BuildDate=unknown

Any help appreciated,

It seems that your jandot.github.io/index.html at master · jandot/jandot.github.io · GitHub file is in html and doesn’t include any head section

In my console, it says the page is trying to load in ‘Quirks mode’. I solved this in the past in one case by changing the base URL e.g from / to https://jandot.github.io/ (unless you are defining the full base URL via command line). If that doesn’t work, perhaps someone else can assist you further.

This does not seem to solve the problem, unfortunately…

Hi Robert,

Strange, I do see a head section in the Saaientist file.

Weirdly enough, the that top-directory index.html as well as posts/index.html have a head section, but the tags/index.html does not.

How about deleting the tags folder altogether? Already, the terms layout handles the layout.

This fixed it. Thanks!


I thought that was the issue when Robert pointed it out. I read somewhere in this forum that creating folders with the same paths as tags or categories causes unexpected results.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.