Gzip: hugo_0.21_Linux-64bit.tar.gz: not in gzip format

I am working on a CI build for a hugo site. I have used CURL to grab the latest 0.21 release, and then am trying to extract the executable.
I have tried:
tar -xvzf hugo_0.21_Linux-64bit.tar.gz (what i would expect would work for a .tar.gz extension)
tar -xvf hugo_0.21_Linux-64bit.tar.gz (after getting a complaint that the stream was not in gzip format)
gunzip hugo_0.21_Linux-64bit.tar.gz

This is complicated somewhat by the fact that I am trying to do this as part of a VSTS (visualstudio.com) build pipeline. I don’t think there is a clean way (on the hosted build) to just fiddle with the CLI commands involved…i have to update the build and see if it works.

Can anyone confirm this issue? Is this release file borked? Or is is possibly a function of the VSTS hosted linux build agent? Have i missed something in the commands I am trying? To my knowledge, the underlying box is some sort of vanilla ubuntu-based docker image…

Anyway…Thanks for your consideration!

That tar file is used with success on Netlify and also several of my CI builds, so archive is fine. I suggest you check the cheksum, try to redownload etc.

Indeed, the archive was fine. I used wget instead of curl to obtain the file and the VSTS “extract archive” task (which internally used /bin/tar -xvf /opt/vsts/work/1/s/hugo_0.21_Linux-64bit.tar.gz -C /opt/vsts/work/1/s/hugo) and it worked. Thanks,