GitHub Pages does not update website

Hi everyone

I’ve set up a personal website using Hugo (papermod theme) and deployed with GitHub Pages and Actions. The repo for the website can be found here:

The problem is that no matter what I try to do, the “Teaching” page of my website will not update. When I build the site on localhost, the page renders as it should:

However, when I navigate to the website (Economics Teaching Materials | teaching), even on completely different machines I only get the following site:

I’m not sure if this is some kind of bug, but I’m at a loss to finding a solution besides maybe deleting my repo and recreating it. I’ve tried editing the index.html files on both my machine and the GitHub site to force some kind of commit/reload, but I’ve been unsuccessful. I even tried removing the entire public folder, pushing to GitHub, building with Hugo, and then pushing to GitHub again. Still nothing. I tried modifying the index.html file to clear caching. It still didn’t fix the problem.

Hugo renders my “Research” page and associated index.html file just fine. It’s only the “Teaching” page that has a problem.

Any ideas? Seems like a very odd and rare issue.

Have you already check the (great) documentation? Host on GitHub Pages | Hugo

Yes, I’ve looked through all that. Unfortunately, I couldn’t find a solution.

It’s very strange because the “Research | David Murakami” page renders absolutely fine.

I couldn’t find any solution :thinking: I tested your code with the same version than your deploy workflow, it’s ok locally.

Apparently you found a solution by changing the category name, have you doing another thing?

Yeah it’s very puzzling. Locally on my computer, everything is fine.

I built the site locally on a friend’s computer too – works fine.

I gave up and just changed the name of the folder from “teaching” to “courses”. That was it.

It’s now working fine. I think it must be some kind of problem on GitHub’s side.

I am suspicious of the fact that you have the public directory under source control. You push public, but the GH action writes to public.

Your .gitignore file should look something like:


I would make that change, then:

git rm -rf resources public
git add -A
git commit -m "Remove public and resources from source control"
git push

After the relevant comment/solution of @jmooring you can try to change the folder name again from “courses” to “teaching” :upside_down_face:

Reverting it back to “teaching” from “courses” causes the problem again! :joy:

Just out of curiosity, you did clear your browser cache, right?

Some pages seem not being updated, what about deleting-your-site-by-changing-the-source, and then changing it back as GitHub Actions?

Yes, multiple times