Favicon not showing up due to https problem

Hi everyone!

For the past weeks i have been trying to solve an issue with the favicon of my Hugo site. It does not seem to be working due to a https error (please see the attached image). I have tried refactoring some pieces of the code and adding some custom html, but i can not get rid of it.

Any help will be highly appreciated.

This is the code: https://github.com/tadeodonegana/tadeodonegana.github.io
This is the site: https://tadeodonegana.com/

*Note: When running the site locally the favicon is shown correctly.


Your baseURL should be the same as the URL you’re hosting your site on, including the protocol. So change your baseURL in the config.toml file to https://tadeodonegana.com/

Thanks for the reply @Arif.
Just did that, but the problem persists. Also tried deleting cache and opening the webpage on another search engine.

Did you really? Here is a screenshot of your source code

You need to change the baseURL to your custom URL including the trailing slash.

Sorry, my bad.

It’s working now! Thanks for your amazing help @Arif !

Welcome and cheers!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.