Favicon disappeared

I am not able to see my favicon anymore! I don’t know what is the exact problem,

this is the code in the partials, under layouts, and the “favicon.ico” is red!

i changed it with

yet still it doesn't work

this happened after i tried to use hugo instead of jekyll and created a github workflows.

this is my code

and this the blog? like the submodule

I watched many tutorials but they all explain differently and they seems to do stuff by using memory! I am so confused!

thanks for the help

Looking at the actual site now (https://137.is/) and it appears you got it to work with Hugo.

Thanks for the answer, that seems true, now it is only a problem with chrome! I deleted the cache but it doesn’t refresh it either. I am still confused about those things.

The root, should be in themes/mytheme/layouts/partials
yet here, in the partials, it is full of red code.
I am using 2 repositories, after following a youtube video and from my understanding

I work on my “blog” folder, and later i push my changes into the “public” folder, that is the one where I have my website hosted on github pages.

Why are the partials in the theme red?

Sorry for my incompetence!

Yes, browser caching (especially with Safari) can often be a problem with favicons. You might try viewing the site, either live or in dev mode, in an “incognito mode” window when you’re trying to make sure.

Thanks for that! So, when i use hugo server, the server created still might have problems with favicon ? cause in the hugo server I wasn’t able to see my favicon either

Yes, if it’s a browser-cache issue, as suggested by your earlier comment — as well as my seeing the favicon on your site. You may also want to try a hard refresh (in some cases, that’s Ctrl + F5).

. . . but the main thing is that, based on the contents of your public folder (which I assume you’ll be .gitignore-ing at some point), it definitely should appear.

Thank you a lot for checking my public folder (yes I was gitignoring before, I delete it cause I though It was that the problem, I started just yesterday with this Hugo-github thinny) out and the hard refresh

control + f5 worked perfectly!!!

1 Like

Glad you got it solved. :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.