HUGO

Error in Rendering the site Part functions/get_icon not found

Hi everyone, I get the following error when tried to update my Academic Theme Hugo site building via RStudio.

Error: Error building site: failed to render pages: render of “page” failed: “/Users/nabinpaudel/website/themes/hugo-academic/layouts/slides/baseof.html:13:45”: execute of template failed: template: slides/single.html:13:45: executing “slides/single.html” at <partial “functions/get_icon” 32>: error calling partial: partial “functions/get_icon” not found

It worked perfectly for windows computer but have issues when I executed the code in a mac platform.

Thanks a lot for your help.

Nabin

That error is saying it can’t fine the file functions/get_icon, which should be located in:

/Users/nabinpaudel/website/themes/hugo-academic/layouts/partials/functions/

So the first thing to check would be to make sure that file exists.

As for on macOS, I use hugo on it without problems, so if it’s a recent move perhaps something didn’t get copied over?

1 Like

Hiya! The Academic theme was created by @neutreno. It has a dedicated issue queue and community chat.

Thank you. Yes, you are right the get_icon is not within the functions folder. I will try to copy it again.

Bets regards,

Nabin