Hugo v0.54.0/extended darwin/amd64 fails to build


#1

Hi!
I am using Hugo with Academic them and was working fine. I even got my page to be published. But recently for some reason I ran into this problem, not sure if it is because a newer version: theme: get v4.1

Here is the error message:

Total in 130 ms
Error: Error building site: failed to render pages: render of “home” failed: execute of template failed: template: index.html:4:3: executing “index.html” at <partial "widget_page…>: error calling partial: “/Users/DC/Desktop/Coding/My_Website/themes/academic/layouts/partials/widget_page.html:23:9”: execute of template failed: template: partials/widget_page.html:23:9: executing “partials/widget_page.html” at <partial $widget $par…>: error calling partial: Partial “widgets/blank.html” not found

This is file line the error is pointing at:

– Widgets –
{{ range $index, $page := where (where .Data.Pages “Section” $section) “.Params.active” “!=” false }}
{{ params := dict "root" “page” $page }}
{{ $widget := printf “widgets/%s.html” ( or $page.Params.widget “custom” ) }}
{{ if in (slice “hero” “hero_carousel”) $page.Params.widget }}
{{ partial $widget $params }}
{{ else }}
<section id="{{ $page.File.TranslationBaseName }}" class=“home-section”>
<div class=“container”>
{{ partial $widget $params }}
</div>
</section>
{{ end }}
{{ end }}

Any help is much appreciated!


#2

Per the error message, it cannot fine this widget partial:

Partial “widgets/blank.html” not found

You’d need to share your code for us to help further.


#3

Thanks for reply. I don’t have that particular file either . How can I remove it from calling this file. Or what other file/code can I provide to help for this


#4

I would need to see your full site code in order to help. If you can’t provide that, then maybe someone else here can help you.


#5

Thanks. My full site lives in github and can be found in this link: https://github.com/danny05158/My_Website


#6

I cloned your site and was able to successfully build it with Hugo v0.54.0 and v0.55.0-DEV-C154C2F7 so there is something happening on your end.


Okay once I ran

git submodule update --remote --merge

to update the theme, I get your same error now.

You’ll need to refer to the Academic Migrate docs https://sourcethemes.com/academic/docs/update/#migrate-content

And the version 4.1 breaking changes https://sourcethemes.com/academic/updates/v4.1.0/#breaking-changes


#7

Thank you! the reason was the update theme. I was able to look at docs