Disquss comments not showing up

Hello there!
I’ve migrated my blog over to Hugo. Everything is working fine, but disqus comments are not working.
If I go to posts that contain comments, they don’t show up. The snipper showing comments in other posts appear, but the actual comments don’t. If I inspect the generated source code, this is the HTML:

    var disqus_shortname = 'fiunchinho';
    var disqus_identifier = 'https:\/\/blog.armesto.net\/jugando-con-conceptos-de-ddd\/';
    var disqus_title = 'Jugando con conceptos de DDD';
    var disqus_url = 'https:\/\/blog.armesto.net\/jugando-con-conceptos-de-ddd\/';

It looks like the identifier and url values slashes are being escaped. I don’t know if that’s a problem and, in that case, how to solve it.

Any clues?

What theme are you using? I just had to add the shortname variable. (I use http://themes.gohugo.io/hugo-icarus/)

If you’re sure that you have your settings on Disqus.com set up properly, your best bet is looking into your theme documentation or theme code.

Hi @septembrium. I’m using Icarus too! As you can see in this image, when you visit a blog’s post, its comments are shown in the snippet, but no in the comment’s section.

The shortname variable is included in the html source code. Do you have escaped urls too? Any ideas?

Can’t say I have any ideas. The issue seems to be related to Disqus but that would only make sense if you didn’t see the comments in the source of your page.

My Hugo journey just started this weekend and my setup is very simple.

I’ve put all my configurations and modifications on github here if you’re interested in comparing: https://github.com/septembrium/de-biercollectie-website

This is the blog: https://biercollectie.be/

So you didn’t have comments before using Hugo? Because I think that’s the problem. Disqus links uses the URL to know which comments to show, but now the url’s is all messed up with escapes characteres. If you don’t have comments prior Hugo, then you won’t notice it

I fixed it. The url’s were wrong BEFORE, not now.

Thank you for your time, anyway!

Glad to read you fixed that issue. As you noted, indeed I didn’t have comments on that domain before.