Disqus not working


I’m totally new to Hugo, and got my site up and running… The problem is that I can’t seem to get hugo to work with disqus comments…

I added the disqusShortname = "...." to config.toml
and then I added the: {{ template "_internal/disqus.html" . }} at the end of the file… What else does it need to get configured correctly… I have this working in Jekyll, but would like to migrate to Hugo :slight_smile:

First, congrats on choosing Hugo. Way better than Jekyll :slight_smile:

I was waiting for others to chime in … I have Disqus working, but I notice that I haven’t done it text-book-style. Do not remember why.

When you do a “View Page Source” on the rendered page, what do you see in ref to Disqus? Do you see your disqusShortname?

When I went through HTML5 Boilerplate recommendations and added a bunch of those things to my site, one aspect was adding a .htaccess with Content-Security-Policy set. This blocked disqus until I allowed the right things through. YMMV.

Since I came to this topic trying to figure out my issue with Disqus, I’ll leave here other things to check:

Message that Disqus provide to us:

We were unable to load Disqus. If you are a moderator please see our troubleshooting guide.

After carefully checking their guide, I still had an issue. It turned out that the reason was I defined my baseurl like this:

baseurl = “//example.org/

Disqus identifier is formed using that, but Disqus itself require URLs with protocol name. Changing baseurl to

baseurl = “http://example.org/

solved my issue.

1 Like

I had the same problem and fixed the same way. Thanks for the tip @Killy :+1:

1 Like

I’m setting my config.toml like baseURL = “http://www.site.studio/” is that wrong?

Hello, you should try baseURL = “http://site.studio/” instead of baseURL = "http://www.site.studio/"