Disabling smart quotes, auto code blocks, and auto hyperlinks?

I’m having trouble finding a way to disable these features:

  • Smart quotes
  • Code blocks based on indentation only (explicit code blocks with three backticks is fine)
  • Automatic hyperlinks (these keep appearing inside my <code> tags which is a no-no)

Anyone know how to do this?

  1. See smartypants here: http://gohugo.io/overview/configuration/#configure-blackfriday-rendering
  2. See hugo config | grep pygm to see how to turn off fenced highlighting (default off in 0.16), but that is probably not what you refer to … I suggest having a look at the black friday to see if there are any extension flags to toggle (see link above).
  3. Have no clue. See above.
1 Like

Thank you @bep! It seems that most of them work except:

- autolink

Doesn’t disable automatic hyperlinks, which is still problematic. Is there anything else I should change to make that work?

I tested this fine just now:

  extensionsmask = ["autolink"]

That is TOML, but provided you get the YAML syntax correct, it should do the trick.


Ah! Thank you! I missed the blackfriday parent in my config. Works great.