Can't verify executable after install (win10)

I followed Hugo install instructions for win10, up to the point where the install needs to be verified.

On entering hugo commands, the win10 command prompt (using admin rights) invariably answers “access denied”.

So basically, stuck at square 1. Any thoughts?

Hi @untld. To clarify, you get that error after running hugo help ?

Hi @zwbetz
yes, I did. i was following install instructions.
Then tried verifying the install using the hugo help command.


The executable is saved at C:\Hugo\bin\hugo.exe?

And it’s on your PATH?

yes, both are the case.

I see. I know you initially tried it in Command Prompt opened as Administrator. Try it without

Other ideas:

  • Save the executable to a folder that you know your account has appropriate rights to
  • If your Win10 is 32 bit, make sure you’re not using the 64 bit Hugo executable

Hi zwbeth,
thanks for the other ideas! I tried out them all out - incl. moving the exe to a folder with more usage rights - but to no avail. the message remains “access is denied”. This win10 version is 64bit…

Hmm. My hunch is it’s something with your Win10 setup/permissions.

I have Hugo 0.55.6 installed on my Win10 laptop and it runs fine.

Actually, would you post a screenshot of Command Prompt after running hugo help? Maybe some other output that’s useful

Hi again,
here’s a screenshot or two, perhaps those will help.

and one more:

and to boot:

Assuming you have gitbash installed, have you tried from there?

From gitbash I get this:

$ file hugo.exe
hugo.exe: PE32+ executable (console) x86-64, for MS Windows

Yep, try what @lar mentioned.

Also, what program did you use to unzip Hugo after you downloaded it? (I use 7zip)

If you’re not opposed to using a package manager, I recommend that you install (and in the future update) Hugo with one. I’ve tried a bunch of Windows package managers and currently prefer Scoop, which you can learn about at:

Good luck!

1 Like