Any good trailheads for troubleshooting/logging


#1

On Ubuntu 18.04, I created some test websites 6 months ago, I believe on version .50. They ran great.

Upgraded to 0.54 and trying out some sample repos from hugo website and contributors (vex-hugo, meghna, mkdocs variants). Nothing renders or I get a few, very few in fact, items from the ‘custom’ set. I have tried git clone and git submodule add, neither has the correct effect. And I change my .toml file accordingly for the right theme. I thought maybe permission issue so I opened folders for read/write for everyone and again no effect.

Reverted back to version 0.52 thinking a few versions back might stabilize, still in same predicament. Also tried hugo extended verson.

Thanks in advance.

As an aside, I have periodically been getting a permissions issue too. I try do a render using ‘hugo’ and server with ‘hugo server’ and the message is permission denied. Even if I use sudo and this doesn’t occur elsewhere on my system.


#2

Where are you saving the hugo binary?


#3

I simply let the ubuntu install process put it in place, “/usr/local/bin/hugo”. I did try the snap version and apt-get versions during my efforts.


#4

What is the exact error message?


#5

You can use the which command to find where the hugo command is located on your system.

[root@fedvm ~]# which hugo
/usr/local/bin/hugo

And the find command to find all hugo executables on your system.

[root@fedvm ~]# find / -type f -executable -name hugo -print
/usr/local/bin/hugo

And print the version

[root@fedvm ~]# find / -type f -executable -name hugo -print -exec  {} version \;
/usr/local/bin/hugo
Hugo Static Site Generator v0.54.0 linux/amd64 BuildDate: unknown

#6

To repeat, only one version of hugo is found, at “/usr/local/bin/hugo”. Version is “Hugo Static Site Generator v0.52 linux/amd64 BuildDate: 2018-11-28T14:06:34Z”. I began this exercise using v0.54

There is no error message, the pages appear to render although they either appear blank (vex2) or render only partials like footers, and one or two other items, not complete pages. Hence my request for logging recommendations.


#7

When I asked about the error message, I was referring to this


#8

For this, have you tried passing the -v flag?


#9

Ah I understand. I don’t get any error messages using verbose. That’s my dilemma.

I get the standard “up and running” on localhost:1313 message.

Oddly, I just noticed I am getting info about a translation bundle not being available for “en” which is my platform’s system/native language. I don’t ever recall a site not rendering because of it though.

Thanks.


#10

I see. Well this seems like an issue with your OS/env configuration, and not something related to hugo. You could confirm this for yourself by installing hugo and running your site on another OS, or the same OS in a VM, etc.


#11

Thanks. I intended to try running from a docker image.