Article generates as a draft even though it's not marked as one

I’ve been deploying my blog without any issues for quite a while until recently. I couldn’t track when did things break but I assume it did sometime around Oct. The backlogs of articles has since been stacking up.

My issue is, hugo isn’t generating some of my articles. But it’s generated as a draft when I run a dev server with this command hugo serve -D --disableFastRender. One thing I’m pretty sure is the blog IS NOT marked as a draft or as a “future” article.

For more context, here’s one such article I’m talking about: blog/ at main · Jarmos-san/blog (

Is there that I’m doing wrong?

I tried running your code and couldn’t reproduce the problem. What version of hugo are you running?

Also, when I cloned the repo it showed two submodules but only 1 could update.

Invoking hugo version outputs this info:

hugo v0.89.0+extended linux/amd64 BuildDate=unknown

For additional context (if that’s required at all), I’m running WSL2 & downloaded Hugo using Homebrew.

And apologies about the submodule issues. Those might’ve crept in when I was trying to re-clone the theme in an attempt to fix the main issue. I made some necessary changes & the submodules should be fixed right now.