Hugo

Academic Website no longer compiling under v0.59

Hello!

Forgive me if this is the wrong forum for posting this issue, but I’ve been using Hugo for the past six months, from two different machines, and have just encountered a problem I cannot solve. On one machine, I have Hugo v0.54.0, and have had no issues compiling my website using the academic theme. But on a new machine, I have Hugo v0.59.0, and it’s providing error messages that I don’t understand, and failing to compile the website when I use “hugo server”. The error messages mean very little to me, and I wondered if someone could translate them for me, so I might be able to diagnose the problem?

Building sites … WARN 2019/11/11 21:57:39 .File.TranslationBaseName on zero object. Wrap it in if or with: {{ with .File }}{{ .TranslationBaseName }}{{ end }}

WARN 2019/11/11 21:57:39 .File.UniqueID on zero object. Wrap it in if or with: {{ with .File }}{{ .UniqueID }}{{ end }}

I’d be happy to provide further details if this makes any sense to you! Many thanks in advance for any help that’s offered.

Many thanks.

Hi there,

There have been quite a few changes in between those two Hugo versions. Make sure you are using an updated version of the theme that is compatible with the latest Hugo.

Thanks for the reply. The academic theme also appears to have gone though several changes since I first started to use it, and unfortunately it isn’t at all clear how to migrate content from my previous version of Academic (v3.3.0) to the latest version (v4.6). I took another tack, and tried to find hugo v0.54 via brew, but no joy there either (following some suggestions here, but without success: https://www.fernandomc.com/posts/brew-install-legacy-hugo-site-generator/). I’ll keep working on this, as I don’t want to give up on this.

The Academic theme has an update guide. I would encourage updating to the latest version Hugo (and by extension Academic), as new features are being added all the time. The wider the version gap, the more breaking changes possibly introduced as well.

Thanks pointyfar. I attempted to work through that yesterday evening, but with so many changes and an absence of backward capability, it wasn’t worth the time invested (I am a novice user, as you can probably tell, and simply wanted to compile my existing website without dealing with the obscure “breaking changes”). I finally managed to get a roll-back of Hugo to v0.56, which has allowed me to compile the site again. I think this is a decent warning to the majority of users to keep track of their academic/hugo versions and not update one without the other, a lesson I have learned the hard way.

Just reading this thread. I have the same issue. @leighfletcher: how did you manage to rollback?

Hi @swvanderlaan - glad I’m not alone! Eventually I succeeded following the instructions on this link and re-installing hugo via 'brew. It took me several attempts to find a version that compiled my website without complaining, but worked eventually.