YAML config file still yields TOML front matter

Edit: I figured it out. See my followup comment below if you’re having the same problem.

I may be missing something here, but I couldn’t find anything about this in the documentation. I have changed my config file from config.toml to config.yml and altered the syntax appropriately (namely, replacing " = " with ": "). However, when I run hugo new [path/file.md], it creates a file with TOML front matter (+++ rather than ---). Is there a way to change this default behavior so that the YAML front matter format is used if the config file is a YAML file? I have tried using config.yaml rather than config.yml to see if it was looking for a specific extension on the config file, but that doesn’t seem to affect anything.

I’m aware of the convert command, but that is a pain to use every time.

In case anyone else is having this problem, I figured it out (as always, within minutes of posting my question despite an hour of searching beforehand).

Add the following to your config file:

metadataformat: "yaml"