Wowchemy site stopped working

I have a Wowchemy site that I update fairly infrequently. I deploy the site via GitHub Actions and I made the mistake of not pinning a specific Go or Hugo version. Now the latest time I tried to build the site it fails and I can’t seem to find a way to get things building again.

I don’t really care about being on older versions of Go, Hugo, or any other dependencies. I’d just like to be able to build my site again. I’ve tried using Go and Hugo versions dating back to January which was the last time the site successfully built. Unfortunately this hasn’t worked and the logs are old enough that they’ve been erased so I can’t consult which specific version was used at the time. A link to the GitHub repository is below and any suggestions would be appreciated.

I assume this is the live site:
https://cs.rit.edu/~dataunitylab/

It has these in the header:

<!-- Last Published: January 30, 2024 -->
<meta name=generator content="Wowchemy 5.7.0 for Hugo">

Unfortunately, by adding the meta-generator tag above, the Academic/Wowchemy/Hugo Blox team is preventing Hugo from rendering its own meta-generator tag, which would have told us what version you were running when the site was last built.

I suggest you reach out to the Academic/Wowchemy/Hugo Blox team:
https://github.com/HugoBlox/hugo-blox-builder/discussions

They also have an active Discord channel:
https://discord.com/invite/z8wNYzb

cc: @alcarazr

Correct on the live site URL. Appreciate the pointers!

1 Like

Updating your Hugo Blox/Wowchemy installation should help

Change this in your config.yaml:

module:
  imports:
    - path: github.com/HugoBlox/hugo-blox-builder/modules/blox-plugin-reveal
    - path: github.com/HugoBlox/hugo-blox-builder/modules/blox-bootstrap/v5

and this in your go.mod:

module github.com/wowchemy/starter-hugo-academic

go 1.19

require (
	github.com/HugoBlox/hugo-blox-builder/modules/blox-plugin-netlify v1.1.2-0.20240513194541-c2e9a799f797
	github.com/HugoBlox/hugo-blox-builder/modules/blox-plugin-reveal v1.1.3-0.20240513194541-c2e9a799f797
	github.com/HugoBlox/hugo-blox-builder/modules/blox-bootstrap/v5 v5.9.8-0.20240513194541-c2e9a799f797
)
1 Like

Thanks so much! That did the trick :slight_smile:

1 Like