Why is the site not accessible?

This seems to be a normal log,but it deny access when i access,and when i try it via nginx,it works,either port 1313 or port 80. now can work.

Can anyone help me?

As the output of Hugo said: http://localhost:1313/

If allows or refuses connections at port 1313 does not matter here. Point your browser to http://localhost:1313/ and see what that gives (probably not too much, give the warnings thrown by Hugo).

Now,i run a hugo site via docker,it can access:,i run it via ubuntu deb,the hugo server is running fine, there is no error message, as shown in the picture of the problem.
But it’s terrible,browser not responding, I confirmed that the ports 1313 and 80 involved are open.
Is there something important here that I’ve forgotten?

Command URL
hugo server http://localhost:1313/
hugo server --bind
hugo server --bind http://localhost:1313/
1 Like

Who is “it” here? The site? The docker container? Something else?

Who is “it” here? Docker? Hugo?

I suppose that you have setup an Ubuntu host and are running docker on it. And Hugo is running in a docker container on this machine. Now, where does the IP address belong to? Is that the container’s exposed IP interface? If so, what does telnet 1313 tell you? What does traceroute give?

And, by the way: This has nothing to do with Hugo. It is about your setup and the virtual network you’re using. People from the docker community should be better positioned to help with this.

Alternatively, simply run Hugo directly on your Ubuntu system, reducing complexity.

I have successfully deployed my site via docker hugo, and the site is now accessible correctly, but no matter how many times I try to run it from the ubuntu installer (hugo-xxx.deb), the site is not accessible

Thankfully, hugo server --bind command worked, I may have made a very low-level mistak

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.